Oggie Harry Rundall, AC3EK, Discusses Elbow Connectors

Male end of elbow connector, photo by AC3EK, used by permission

Harry reports: “I had asked about erratic power behavior on the ICOM 7300 on the mode FT8 last Saturdays Q&A. Well it turns out it was the elbow connector I had in line on the back of the rig to my jumper going to my MFJ-697 dummy load/SWR meter. Being a Field Engineer, back the day, with Hewlett Packard Medical (1969-1979), I applied the good ole troubleshooting methods. Lightly tapping on the back right hand corner of the cover to the rig, when it was in the tune function of FT8, I could eliminate the problem, i.e. recover proper power output. Next I grabbed the body of the elbow connector and ever so slightly rocked it and sure enough the problem appeared/disappeared. Next, removed the connector and placed the jumper RG8X directly into the rig. Problem went away. I tapped the top- while in tune mode, and no repeat of the problem. Talking to a fellow ham buddy about this He heard that these elbow connectors can be a problem. Notice in the attached photo (Taken with a Nikon 7000, Sigma lens set for micro photo 1/1000 at F13) of the pin of the male part of the connector in the blown up photo notice the scarring to the pin. Thought I would share this for your library of troubleshooting connectors issue. All is good now!! 73s Harry AC3EK”

This entry was posted in Ham Radio blog entries. Bookmark the permalink.

2 Responses to Oggie Harry Rundall, AC3EK, Discusses Elbow Connectors

  1. Chandrasekhara RAO thaty says:

    Thank you very much sir

  2. Eddy says:

    Good stuff Dave!! I’m not a big fan of PL259 elbows, just another place for a problem….but I do use them if needed.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.